FANDOM


These are for Cisco 877 ADSL Routers:

  • show config
show run
  • show IP addresses
show int
  • save running config
write mem
  • get adsl status
show dsl int atm0
  • ls flash
sh flash
  • reset to factory default (GUI mode)
copy flash:/sdmconfig-8xx.cfg startup-config
reload
  • reset to empty config
erase startup-config
reload
  • enable interfaces
interface Vlan1
no shut
interface FastEthernet0
no shut
interface FastEthernet1
no shut
interface FastEthernet2
no shut
interface FastEthernet3
no shut
interface ATM0
no shut
  • upload config (terminal)
conf t
<paste your config>
write mem
reload
  • upload config (scp)
copy scp:cisco.txt startup-config
  • update firmware (network. can use tftp or scp)
delete flash:c870-advsecurityk9-mz.124-15.T4.bin 
copy tftp:c870-advsecurityk9-mz.124-15.T5.bin flash:
  • enable ssh
cry key generate rsa
ip ssh time-out 60
ip ssh authentication-retries 2
  • port forwards (forwards ssh to 192.168.0.11):
ip nat inside source static tcp 192.168.0.11 22 interface Dialer0 22
  • port forward range (assuming 192.168.0.254 is the VOIP server):
ip nat pool VOIP 192.168.0.254 192.168.0.254 netmask 255.255.255.0 type rotary
ip access-list extended VOIP
permit udp any any range 10000 20000
exit
ip nat inside destination list VOIP pool VOIP

QoSEdit

This is for incoming only and is a work in progress:

ip access-list extended ICMP
 permit icmp any any
ip access-list extended SIP
 permit icmp any any
 permit tcp any any eq 5060
 permit udp any any eq 5060
 permit udp any any range 10000 20000
class-map match-any ICMP
 match access-group name ICMP
class-map match-any SIP
 match access-group name SIP
policy-map FAIR
 class ICMP
  priority 10
 class SIP
  priority 100
 class class-default
  fair-queue
int di1
 bandwidth 600
 rate-limit output 536000 5000 5000 conform-action transmit exceed-action drop
 service-policy input FAIR

Working configEdit

!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname cisco
!
boot-start-marker
boot-end-marker
!
logging queue-limit 1000
logging buffered 100000
logging reload alerts
logging rate-limit console 20
!
no aaa new-model
clock timezone AEST 10
clock summer-time AEDST recurring last Sun Oct 0:01 last Sun Mar 0:01
!
!
dot11 syslog
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.0.1 192.168.0.49
ip dhcp excluded-address 192.168.0.100 192.168.0.254
!
ip dhcp pool dhcppool
   import all
   network 192.168.0.0 255.255.255.0
   dns-server 61.88.88.88 202.139.83.3 
   default-router 192.168.0.253 
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
ip domain name n3il.com
ip name-server 61.88.88.88
ip name-server 202.139.83.3
!
!
!
username cisco privilege 15 secret 0 <PASSWORD-REMOVED>
! 
!
archive
log config
 hidekeys
!
!
ip ssh time-out 60
ip ssh authentication-retries 2
!
!
!
!
!
!
!
interface ATM0
 no ip address
 logging event subif-link-status
 no atm ilmi-keepalive
 dsl operating-mode auto 
!
interface ATM0.1 point-to-point
 description Exetel
 pvc 8/35 
  tx-ring-limit 3
  pppoe-client dial-pool-number 3
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Vlan1
 ip address 192.168.0.253 255.255.255.0
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip nat inside
 ip virtual-reassembly
 ip tcp adjust-mss 1350
 no ip mroute-cache
!
interface Dialer0
 description Exetel
 ip address negotiated
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 no ip mroute-cache
 tx-ring-limit 3
 tx-queue-limit 3
 dialer pool 1
 dialer-group 1
 keepalive
 no cdp enable
 ppp authentication chap callin
 ppp chap hostname <ADSL-USERNAME-REMOVED>
 ppp chap password 0 <ADSL-PASSWORD-REMOVED>
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer0
!
no ip http server
no ip http secure-server
ip nat inside source list 1 interface Dialer0 overload
!
!
access-list 1 permit 192.168.0.0 0.0.0.255
!
!
!
control-plane
!
!
line con 0
 password <PASSWORD-REMOVED>
 login
 no modem enable
 transport output all
line aux 0
 transport output all
line vty 0 4
 access-class 99 in
 exec-timeout 20 0
 privilege level 15
 password <PASSWORD-REMOVED>
 login local
 transport input all
 transport output all
!
scheduler max-task-time 5000
end

Ad blocker interference detected!


Wikia is a free-to-use site that makes money from advertising. We have a modified experience for viewers using ad blockers

Wikia is not accessible if you’ve made further modifications. Remove the custom ad blocker rule(s) and the page will load as expected.